Powered by Jitbit .Net Forum free trial version. dismiss

HomeBugs

Bugs

Not able to authenticate through Router Messages in this topic - RSS

freelance9989
freelance9989
Posts: 6


12.05.2018
freelance9989
freelance9989
Posts: 6
Hi,

I am planning to use RADIUS authentication and accounting for my home router. I own a cloud sever and i just set up TekRadius on the server and configured my router with IP,Port and shared key(Default Client and did not add any other client). I am not able to authenticate.


I tested the server Authentication using 'ntradping' and everything works, i am getting access-accept in response.

Can you please help me figure out. And also can anyone suggest how to know if my home router or in general home routers supports accounting.
0 link
Admin
Admin
Administrator
Posts: 4869


12.05.2018
Admin
Admin
Administrator
Posts: 4869
Hi,

Can you send TekRADIUS log entries (Accessible through File menu) after setting log level to debug at Settings / Service Parameters for a failed authentication attempt?

Best regards,

Yasin KAPLAN
0 link
freelance9989
freelance9989
Posts: 6


12.05.2018
freelance9989
freelance9989
Posts: 6
Hi,

I am not getting anything logged in the logs. My logs are empty.

All i have is just the below line.


11.05.2018 23:47:12.404 - TekRADIUS Service 5.4.2 is (Microsoft Windows NT 6.2.9200.0) running under account 'NT AUTHORITY\SYSTEM'. Internet connection available.



Thank You.
0 link
Admin
Admin
Administrator
Posts: 4869


12.05.2018
Admin
Admin
Administrator
Posts: 4869
Can you ping your home router from TekRADIUS machine? Is there any firewall or IP filter configured between TekRADIUS and your home router?
0 link
freelance9989
freelance9989
Posts: 6


12.05.2018
freelance9989
freelance9989
Posts: 6
As far as i know there is no Firewall configured. I did another test. I added a user to Default group, with User-Credit as 30. In the Default user group, i added Credit-Unit as Bytes-sum.

After that is sent 'Accounting Start' request with Acct-Input-Octets as 40. Then i tried to authenticate the user and the authenticate passed.
0 link
Admin
Admin
Administrator
Posts: 4869


12.05.2018
Admin
Admin
Administrator
Posts: 4869
How had you tested previously? I mean, how had you configured the user profile?
0 link
freelance9989
freelance9989
Posts: 6


12.05.2018
freelance9989
freelance9989
Posts: 6
I used same software 'ntradping' to test. I created a new user(radiusserver) to Default group(existing group in groups tab). Then i added User-Credit as 30 to that user(radiusserver). In the Default existing user group, i added Credit-Unit attribute as Bytes-sum.

After that is sent 'Accounting Start' request with Acct-Input-Octets as 40 from 'ntradping'.


When i did that, i am expecting user authentication to fail as the user-credit limit has exceeded.


But the user authentication has passed.
0 link
Admin
Admin
Administrator
Posts: 4869


12.05.2018
Admin
Admin
Administrator
Posts: 4869
RADIUS authentication fails if user credit <= 0
0 link
freelance9989
freelance9989
Posts: 6


12.05.2018
freelance9989
freelance9989
Posts: 6
OK. When we send a Accounting Update request with acct-input-octets as 40 when the user-credit of the user is 30.

Does it automatically decreases? How should i compose my Account Request to verify this? Can you please share the step to validate the User-Credit attribute.
0 link
Admin
Admin
Administrator
Posts: 4869


12.05.2018
Admin
Admin
Administrator
Posts: 4869
TekRADIUS can send Packet of Disconnect (PoD) or execute a user defined session kill command when a user’s credit is fully consumed. This requires SP license. I can provide you a trial key. But your router must support RADIUS disconnect requests or provide a function to disconnect user sessions.
0 link
freelance9989
freelance9989
Posts: 6


12.05.2018
freelance9989
freelance9989
Posts: 6
User-Credit update worked. Still wondering why my router is not even sending auth. requests.
0 link
Admin
Admin
Administrator
Posts: 4869


12.05.2018
Admin
Admin
Administrator
Posts: 4869
What type of route do you use? I mean vendor and model?
0 link






Powered by Jitbit Forum 8.3.8.0 © 2006-2013 Jitbit Software