Powered by Jitbit .Net Forum free trial version. dismiss

HomeInstallation

Installation Issues

'Calling-Station-Id' value does not match Messages in this topic - RSS

Alan Summerfield
Alan Summerfield
Posts: 49


27.11.2017
Alan Summerfield
Alan Summerfield
Posts: 49
Hi,
I just did a fresh install of TekRadiusLT 5.3.412 and copied the .ini .db and db3 files over from the previous 5.3.2.1 folder.

--------------------------------------
27.11.2017 15:05:38.379 - TekRADIUS LT Service 5.3.4.12 is being started (Microsoft Windows NT 6.1.7601 Service Pack 1) [en-US] runs under account 'NT AUTHORITY\SYSTEM'. Internet connection available. (43F5FA42516A)
27.11.2017 15:05:40.551 - Initializing performace counters.
27.11.2017 15:05:40.583 - DailyBreakouts view re-created.
27.11.2017 15:05:40.661 - AcctUserList view re-created.
27.11.2017 15:05:41.536 - .NET Framework Version: 4.6.2 or later
27.11.2017 15:05:41.536 - Initializing clients table.
27.11.2017 15:05:42.473 - Clients table initialized.
27.11.2017 15:05:42.676 - Reading dictionary.
27.11.2017 15:05:45.426 - Default EAP method is PEAP.
27.11.2017 15:05:46.848 - Starting TekRADIUS LT Authentication [UDP (1812)] thread.
27.11.2017 15:05:47.051 - TekRADIUS LT Authentication (UDP) thread is started.
27.11.2017 15:05:47.739 - Starting TekRADIUS LT Authentication [TCP (1812)] thread.
27.11.2017 15:05:48.254 - TekRADIUS LT Authentication (TCP) thread is started.
27.11.2017 15:05:49.817 - DHCP server initialized.
27.11.2017 15:05:49.895 - TekRADIUS LT Service is listening 129.206.50.246 (1 client(s))
27.11.2017 15:05:49.958 - DHCP Server enabled.
27.11.2017 15:05:50.067 - Startup completed.
27.11.2017 15:05:55.551 - Performace counters initialized.
--------------------------------------


All looks as it did in the previous version except that most (but not all) requests result in the error message and are denied access:

--------------------------------------
27.11.2017 14:54:58.347 - RadAuth req. from : xx.xx.xx.166:50568 [UDP]

Size : 173 / 173
Identifier : 11
Attributes :

NAS-Port-Type = 19
Called-Station-Id = C4-xx-xx-xx-xx-80:Neurobiologie
Connect-Info = CONNECT 11Mbps 802.11b
Calling-Station-Id = 8C-xx-xx-xx-xx-E9
NAS-IP-Address = xx.xx.xx.166
NAS-Identifier = Neurobiologie
User-Name = 8cxxxxxxxxe9

27.11.2017 14:54:58.347 - Check attribute 'Calling-Station-Id' value does not match for user '8cxxxxxxxxe9'.
--------------------------------------

Any idea what's wrong here?

Alan
0 link
Admin
Admin
Administrator
Posts: 4845


27.11.2017
Admin
Admin
Administrator
Posts: 4845
Have you checked user profile '8cxxxxxxxxe9'? Which attributes are configured for this user? Do all failed authentication requests come from xx.xx.xx.166?
0 link
Alan Summerfield
Alan Summerfield
Posts: 49


27.11.2017
Alan Summerfield
Alan Summerfield
Posts: 49
Yes I've checked the User Profile. This is set to for 'Check / Calling Station ID 8cxxxxxxxxe9' to use the MAC number for authentication. This has worked until now.

The failed requests come from 3 different IPs which are 3 Access Points from Netwear with 2 identical models and one different model of Access Point.

Alan
0 link
Admin
Admin
Administrator
Posts: 4845


27.11.2017
Admin
Admin
Administrator
Posts: 4845
Latest version requires you to enter Calling-Station-Id in XX:XX:XX:XX:XX:XX format (using capital letters).
0 link
Alan Summerfield
Alan Summerfield
Posts: 49


28.11.2017
Alan Summerfield
Alan Summerfield
Posts: 49
Is there a simple way to extract the list of Calling Station IDs, change the case in a text editor and import them back into TekRadius? I have no experience with databases.
Alan
0 link
Admin
Admin
Administrator
Posts: 4845


28.11.2017
Admin
Admin
Administrator
Posts: 4845
Please apply update at https://www.kaplansoft.com/tekradius/release/TekRADIUSLT-Update.zip
You will see a new menu option called "Normalize MAC addresses". Use this function normalize MAC address definitions in your database.
0 link
Alan Summerfield
Alan Summerfield
Posts: 49


28.11.2017
Alan Summerfield
Alan Summerfield
Posts: 49
It works! Thanks very much.
Alan
0 link






Powered by Jitbit Forum 8.3.8.0 © 2006-2013 Jitbit Software